WebCollector Maven支持(含所有依赖jar包)

  |   0 评论   |   0 浏览

虽然WebCollector封装的功能很强大,使用也简单,但是因为WebCollector集成的有selenium,selenium本身依赖了很多jar包,而且不同版本之间区别较大,无语的是WebCollector作者只提供了一个selenium-java 的maven下载实例,而实际上WebCollector还依赖selenium的一些驱动jar等等,而且必须引入WebCollector对应的版本,而作者根本没有说需要引入哪个版本,只是在GitHub上给了一个jar包压缩包,这里面的只是很少的一部分jar包,实际上还需要很多的jar包,经过昨天一上午的努力把所有的jar包都从mvnrespository.org上面找全了,在此对WebCollector作者不提供WebCollector依赖的所有jar包,进其讨论群还要交10块钱的行为喷一下。

然后在这里给出我的时间成果,如果想使用WebCollector maven项目pom文件如下

pom.xml

 

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
	<modelVersion>4.0.0</modelVersion>
	<groupId>top.wys</groupId>
	<artifactId>WebCollector_Maven</artifactId>
	<packaging>war</packaging>
	<version>0.0.1-SNAPSHOT</version>
	<name>WebCollector_Maven Maven Webapp</name>
	<url>http://maven.apache.org</url>
        <!- 郑明亮 2017年2月22日11:18:39 -->
	<properties>
	<spring.version>4.3.6.RELEASE</spring.version>
	</properties>
	<dependencies>
		<dependency>
			<groupId>org.springframework</groupId>
			<artifactId>spring-core</artifactId>
			<version>${spring.version}</version>
		</dependency>
		<dependency>
			<groupId>junit</groupId>
			<artifactId>junit</artifactId>
			<version>4.11</version>
			<scope>test</scope>
		</dependency>
		<!-- 日志相关 -->
		<dependency>
			<groupId>org.slf4j</groupId>
			<artifactId>slf4j-api</artifactId>
			<version>1.7.22</version>
		</dependency>
		<dependency>
			<groupId>org.slf4j</groupId>
			<artifactId>slf4j-log4j12</artifactId>
			<version>1.7.22</version>
		</dependency>
		<dependency>
			<groupId>log4j</groupId>
			<artifactId>log4j</artifactId>
			<version>1.2.17</version>
		</dependency>
		<dependency>
			<groupId>org.apache.commons</groupId>
			<artifactId>commons-lang3</artifactId>
			<version>3.3.2</version>
		</dependency>
	&lt;dependency&gt;
		&lt;groupId&gt;commons-io&lt;/groupId&gt;
		&lt;artifactId&gt;commons-io&lt;/artifactId&gt;
		&lt;version&gt;2.4&lt;/version&gt;
	&lt;/dependency&gt;

	&lt;dependency&gt;
		&lt;groupId&gt;org.json&lt;/groupId&gt;
		&lt;artifactId&gt;json&lt;/artifactId&gt;
		&lt;version&gt;20160810&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.apache.xmlgraphics&lt;/groupId&gt;
		&lt;artifactId&gt;batik-ext&lt;/artifactId&gt;
		&lt;version&gt;1.8&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/xml-apis/xml-apis --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;xml-apis&lt;/groupId&gt;
		&lt;artifactId&gt;xml-apis&lt;/artifactId&gt;
		&lt;version&gt;1.4.01&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/cn.edu.hfut.dmic.webcollector/WebCollector --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;cn.edu.hfut.dmic.webcollector&lt;/groupId&gt;
		&lt;artifactId&gt;WebCollector&lt;/artifactId&gt;
		&lt;version&gt;2.32&lt;/version&gt;
	&lt;/dependency&gt;

	&lt;!-- https://mvnrepository.com/artifact/org.apache.commons/com.springsource.org.apache.commons.collections --&gt;
	&lt;!-- 如果maven无法下载,那就手动去上面这个网址下载吧,这个jar我在不使用maven架构时,没有就报错,使用maven就不报错了,应该是依赖包中已包含--&gt;
	&lt;!-- &lt;dependency&gt;
		&lt;groupId&gt;org.apache.commons&lt;/groupId&gt;
		&lt;artifactId&gt;com.springsource.org.apache.commons.collections&lt;/artifactId&gt;
		&lt;version&gt;3.2.0&lt;/version&gt;
	&lt;/dependency&gt; --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;commons-codec&lt;/groupId&gt;
		&lt;artifactId&gt;commons-codec&lt;/artifactId&gt;
		&lt;version&gt;1.10&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;commons-dbcp&lt;/groupId&gt;
		&lt;artifactId&gt;commons-dbcp&lt;/artifactId&gt;
		&lt;version&gt;1.4&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.apache.httpcomponents&lt;/groupId&gt;
		&lt;artifactId&gt;httpclient&lt;/artifactId&gt;
		&lt;version&gt;4.5.3&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.jsoup&lt;/groupId&gt;
		&lt;artifactId&gt;jsoup&lt;/artifactId&gt;
		&lt;version&gt;1.10.1&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.apache.httpcomponents&lt;/groupId&gt;
		&lt;artifactId&gt;httpclient-cache&lt;/artifactId&gt;
		&lt;version&gt;4.5.3&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.apache.httpcomponents&lt;/groupId&gt;
		&lt;artifactId&gt;httpclient-win&lt;/artifactId&gt;
		&lt;version&gt;4.5.3&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/com.sleepycat/je --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;com.sleepycat&lt;/groupId&gt;
		&lt;artifactId&gt;je&lt;/artifactId&gt;
		&lt;version&gt;5.0.73&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/xerces/xercesImpl --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;xerces&lt;/groupId&gt;
		&lt;artifactId&gt;xercesImpl&lt;/artifactId&gt;
		&lt;version&gt;2.6.0&lt;/version&gt;
	&lt;/dependency&gt;


	&lt;!-- https://mvnrepository.com/artifact/com.googlecode.juniversalchardet/juniversalchardet --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;com.googlecode.juniversalchardet&lt;/groupId&gt;
		&lt;artifactId&gt;juniversalchardet&lt;/artifactId&gt;
		&lt;version&gt;1.0.3&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;mysql&lt;/groupId&gt;
		&lt;artifactId&gt;mysql-connector-java&lt;/artifactId&gt;
		&lt;version&gt;5.1.27&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/net.sourceforge.nekohtml/nekohtml --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;net.sourceforge.nekohtml&lt;/groupId&gt;
		&lt;artifactId&gt;nekohtml&lt;/artifactId&gt;
		&lt;version&gt;1.9.22&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-htmlunit-driver --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.seleniumhq.selenium&lt;/groupId&gt;
		&lt;artifactId&gt;selenium-htmlunit-driver&lt;/artifactId&gt;
		&lt;version&gt;2.52.0&lt;/version&gt;
	&lt;/dependency&gt;

	&lt;!-- https://mvnrepository.com/artifact/org.w3c.css/sac --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.w3c.css&lt;/groupId&gt;
		&lt;artifactId&gt;sac&lt;/artifactId&gt;
		&lt;version&gt;1.3&lt;/version&gt;
	&lt;/dependency&gt;

	&lt;!-- https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-remote-driver --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.seleniumhq.selenium&lt;/groupId&gt;
		&lt;artifactId&gt;selenium-remote-driver&lt;/artifactId&gt;
		&lt;version&gt;2.52.0&lt;/version&gt;
	&lt;/dependency&gt;
	&lt;!-- https://mvnrepository.com/artifact/org.seleniumhq.selenium/htmlunit-driver --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.seleniumhq.selenium&lt;/groupId&gt;
		&lt;artifactId&gt;htmlunit-driver&lt;/artifactId&gt;
		&lt;version&gt;2.24&lt;/version&gt;
	&lt;/dependency&gt;

	&lt;!-- https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-java --&gt;
	&lt;dependency&gt;
		&lt;groupId&gt;org.seleniumhq.selenium&lt;/groupId&gt;
		&lt;artifactId&gt;selenium-java&lt;/artifactId&gt;
		&lt;version&gt;3.0.1&lt;/version&gt;
	&lt;/dependency&gt;


&lt;/dependencies&gt;
&lt;build&gt;
	&lt;finalName&gt;WebCollector_Maven&lt;/finalName&gt;
&lt;/build&gt;
&lt;dependencyManagement&gt;
	&lt;dependencies&gt;
		&lt;dependency&gt;
			&lt;groupId&gt;commons-collections&lt;/groupId&gt;
			&lt;artifactId&gt;commons-collections&lt;/artifactId&gt;
			&lt;version&gt;3.2.2&lt;/version&gt;
		&lt;/dependency&gt;
	&lt;/dependencies&gt;
&lt;/dependencyManagement&gt;

</project>

 

如果没有使用maven项目的话,如果有积分的话那么就用打包下载1去我的CSDN上下载吧,辛辛苦苦想赚2个积分,如果没有积分的朋友可以选择打包下载2(七牛云)进行免费下载。

所有依赖jar打包下载1

点我下载

所有依赖jar打包下载 2

点我下载

 

jar包截图

Webcollector所有依赖jar包截图