问题之HTTP Status 500 - Unable to compile class for JSP更优雅的解决方案 有更新!

  |   0 评论   |   351 浏览

    一上午的坑,终于找到合适的解决方案跳出来了,这个问题其实到现在为止还是Apache的一个未解决的bug,https://bz.apache.org/bugzilla/show_bug.cgi?id=57020

     不过,通过一上午的努力,在这有了更优雅的解决方案

    HTTP Status 500 - Unable to compile class for JSP:
    
    type Exception report
    
    message Unable to compile class for JSP:
    
    description The server encountered an internal error that prevented it from fulfilling this request.
    
    exception
    
    org.apache.jasper.JasperException: Unable to compile class for JSP: 
    
    An error occurred at line: [65] in the generated java file: [C:\zml\Tomcat 8.0\work\Catalina\localhost\DeveloperClubWeb\org\apache\jsp\index_jsp.java]
    The method getDispatcherType() is undefined for the type HttpServletRequest
    
    Stacktrace:
    	org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:102)
    	org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:198)
    	org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:450)
    	org.apache.jasper.compiler.Compiler.compile(Compiler.java:361)
    	org.apache.jasper.compiler.Compiler.compile(Compiler.java:336)
    	org.apache.jasper.compiler.Compiler.compile(Compiler.java:323)
    	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:585)
    	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:363)
    	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:396)
    	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:340)
    	javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
    	org.springframework.web.servlet.view.InternalResourceView.renderMergedOutputModel(InternalResourceView.java:168)
    	org.springframework.web.servlet.view.AbstractView.render(AbstractView.java:303)
    	org.springframework.web.servlet.DispatcherServlet.render(DispatcherServlet.java:1244)
    	org.springframework.web.servlet.DispatcherServlet.processDispatchResult(DispatcherServlet.java:1027)
    	org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:971)
    	org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:893)
    	org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:970)
    	org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:861)
    	javax.servlet.http.HttpServlet.service(HttpServlet.java:622)
    	org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:846)
    	javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
    	org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:85)
    	org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
    note The full stack trace of the root cause is available in the Apache Tomcat/8.0.22 logs.
    
    

    产生问题分析:

    使用maven对jar包进行管理,因此当使用SpringMVC框架的时候肯定会手动的配置 servlet-api.jar 、jsp-api.jar等jar包到项目中,否则一些jsp肯定会无情的报错(找不到对应jar包的),但是当配置了servlet-api.jar之后,就可能会与tomcat容器中的jar包冲突,导致出现以上问题,无法找到jsp,该问题在tomcat8即以上才会出现,在tomcat7即以下是没有问题的

    那么如果使用tomcat8及更高版本的童鞋们就可能会用到以下解决方案了

    解决方案:

    • 方案一:发布项目后,到webapps目录下把项目中引用的servlet-api-xxx.jar移除掉,重新启动tomcat,记得是重新启动tomcat,而不是重新发布项目
    • 方案二:直接在项目中添加 Server Library 

            在项目上右键-->build Path -->Add Library -->Server Library --> Apache Tomcat v8.0(前提是,已经将tomcat8及更高版本集成到Eclipse、或MyEclipse或使用的其他IDE中)

    以上两种解决方案,对于使用maven项目总有点治标不治本,使用maven目的就是对jar包依赖完全控制,如果到时候,还需要手动添加jar或者删除jar,那在团队协作的时候,无疑是很麻烦的,所以在这再提供一种解决方案

    • 方案三:添加scope限制为provided
    <dependency>
    			<groupId>tomcat</groupId>
    			<artifactId>servlet-api</artifactId>
    			<version>5.5.23</version>
    			<scope>provided</scope>
    		</dependency>

     

    添加provided限制:

    容器或JDK已提供范围,表示该依赖包已经由目标容器(如tomcat)和JDK提供,只在编译的classpath中加载和使用,打包的时候不会包含在目标包中。最常见的是j2ee规范相关的servlet-api和jsp-api等jar包,一般由servlet容器提供,无需在打包到war包中,如果不配置为provided,把这些包打包到工程war包中,在tomcat6以上版本会出现冲突无法正常运行程序(版本不符的情况)

     

     

     

    评论

    发表评论

    validate